Excel: Doplněk pro vypsání částky slovy

Odkazy na užitečný software. Doporučte ostatním praxí ověření software.

Excel: Doplněk pro vypsání částky slovy

Odeslatod Path » 15.07.07 5:00 (Ne)

Add-In: Částka (číslo) vypsané slovy pro MS Excel.

Popis: Doplněk pro MS Excel 2003/2007, který umožňuje vypsat částku slovy. Vhodné pro objednávky, cenové nabídky, faktury aj.

Poznámka: Tenhle mini skript jsem psal už několikrát, ale vždy jsem si ho šikovně smazal. Tady dávám k dispozici mou poslední verzi, která určitě funguje.

Stažení pro MS Excel 2007:
Slovy_2007.zip

Stažení pro MS Excel 2003:
Slovy_2003.zip

Jak se instalují dopňky se každý dočte v nápovědě Excelu. V každém případě doporučuji umístit soubor Slovy.xla (Excel 2003) nebo Slovy.xlam (Excel 2007) do složky, kde zůstane trvale uložen, např.: C:\Program Files\Microsoft Office\Office12\1029 pro Office 2007 nebo C:\Program Files\Microsoft Office\OFFICE11\Library pro Office 2003.

Instalace doplňku pro Excel 2003: Nástroje > Doplňky > Procházet..., pak vybrat soubor Slovy.xla

Instalace doplňku pro Excel 2007
: Tlačítko office > Možnosti aplikace Excel > Doplňky > Tlačítko přejít... > Procházet..., pak vybrat soubor Slovy.xlam

Náhled:
Obrázek
Obrázek
Nemáte oprávnění prohlížet přílohy.
Obrázek uživatele
Path
Site Admin
 
Příspěvků: 3406
Registrace: 15.05.07 23:15 (Út)

Re: Excel: Doplněk pro vypsání částky slovy

Odeslatod Mirek » 02.12.08 10:52 (Út)

dobrý den, chtěl jsem se zeptat, zda to jde nastavit aby to ukazovalo i zápornou hodnotu (-) ?
Mirek
 

Re: Excel: Doplněk pro vypsání částky slovy

Odeslatod Path » 04.12.08 13:07 (Čt)

Nemám teď po ruce zdrojový kód (nevím kam jsem ho zašantročil), ale dalo by se to dočasně ošetřit například tímto vzorcem:

Code: Vybrat vše
=KDYŽ(A1<0;"minus " & CastkaSlovy(ABS(A1);1;1;1);CastkaSlovy(A1;1;1;1))



Se zápornými hodnotami jsem původně nepočítal
Obrázek uživatele
Path
Site Admin
 
Příspěvků: 3406
Registrace: 15.05.07 23:15 (Út)

Re: Excel: Doplněk pro vypsání částky slovy

Odeslatod Anonymous » 07.12.08 16:08 (Ne)

Děkuji funguje toObrázek
Anonymous
 


Zpět na Doporučený Software

Kdo je online

Online uživatelé v tomto fóru: Brandwatch/Magpie [Bot], CommonCrawl [Bot] a 1 návštěvník.